Archive for February, 2009

Native Install of Redhat v5.3 Linux on a MacPro

Saturday, February 28th, 2009

The simplest way to install RedHat Linux v5.3 natively on a MacPro is to do the following:

Download RedHat EL v5.3 for Server or Desktop…or buy it.  I used the 64bit version for some kick butt performance.

Have a dedicated drive for Linux

Power off the system and unplug it

Unplug powered devices such as Ethernet

Pull out the other drives such as MacOS or Windows

Note: If you leave the drives in, Grub may recognize them and overwrite partition sectors or MBR.  I usually pull the drives out a couple inches, leaving the case lid off.  Grub is smart, perhaps too smart!

Boot up the system with the first Redhat CD or DVD in the drive.

Important Note: All non-MacOS drives and CD’s are recognized as Windows in the Boot Menu!  Weird huh?

Note: If you forget to pop in the CD/DVD, just hold down the ALT key then press the eject button (or F12 if you have a PC keyboard) or just type in eject /dev/sr0 or /dev/sr1 at the command prompt if you’re in redhat.

Install Linux as you normally and partition it as you normally would and remove all partitions.

Check the Review and modify partitioning layout

Check Configure advanced boot loader options

Selection /dev/sda1 First sector of boot partition

Note: Since the BIOS is EFI, it will not recognize MBR’s without a third party program

Carry on and install as you normally would.

After installation, you will get some error messages.  Don’t panic, unless the kernel panics!

The error message “PCI:BIOS Bug:MCFG area at e0000000 is not E820-reserved
 PCI:NOT Using MMCONFIG” according to Redhat article ID 2199 is informational only.  Redhat will fix this in future releases so users won’t freak out.
If you receive the error message “i8042.c : no controller found”, then you likely have an Nvidia video card.  Nvidia has some driver issues and you can download a driver from Nvidia after you update the kernel.
 

If you receive the error Kernel panic, you been screwing around haven’t you?
 

Error is : Kernel panic –  not syncing: Attempted to kill init!

To fix the kernel panic:
Boot off of the Linux installer CD/DVD:
Type “linux rescue” without the quotes
Click Ok to English
Click Ok to us
Click No to network interfaces
Click Continue to /mnt/sysimage
Click OK
At the command line type the following:
grub
device (hd0) /dev/sda
Note: Don’t worry if you’re hard drive is not the first one, hd0 is the only drive the system will see since you pulled the others out.
find /grub/stage1
Note: the output should be find /grub/stage1 (hd0,0)
root (hd0,0)
Note: The output should be root (hd0,0) Filesystem type is ext2fs, partition type 0x83
setup (hd0)
Note: there’s a lot of output here.
Quit
reboot
Next hold down the alt key
Remove the Linux CD/DVD.
Everything should work, if not…..Well, that sucks doesn’t it??
Ok, if that doesn’t work done then it’s probably picking up the last configuration (Linux is too smart..or maybe too stupid?).  Download a utility called Gparted and wipe out the partition table.
Note: Gparted will work but when you boot off the CD, load it into RAM.  Otherwise you will be able to erase, but not create partitions on the MacPro.  Yeah, it’s a bug.  I like to create an NTFS partition just to make sure I wiped out the old one.
Unplug everything and put the drives back in.
 

In order to go to the Linux partition, just hold down the ALT key and select the RedHat drive.  

MacPro ESATA card for everthing

Monday, February 23rd, 2009

This post is in regards to adding an ESATA card to a MacPro.  You’re probably thinking, why add an ESATA card when you have 2 SATA ports that can be converted to ESATA with a simple cable.  The SATA ports onboard are only supported in AHCI mode.  Whenever you boot into Linux or Windows you’re automatically put into legacy mode which does not see the extra ports aka your drives.
My best candidate for an ESATA card was the Adaptec 1225SA.  This card has support for Linux RPMS and Windows drivers out the wazoo. (I’m not a fan a recompiling the kernel for drivers that should already be there and I like the official support)  However, Adaptec has no support for MacOS.
I received a 1225SA revision 3 which had a Silicon Image chipset and a Silicon Storage Technology chip.

The chipsets were:

Silicon Image
SII3132CNU
QN4863.1-17
0725
AD02CX2

Silicon Storage Technology
39VF040
70-4C-NHE
0721003-K

The highest drivers that are supported from the Silicon Image website are 10.5.1…Boo!  I installed several variants, but alas it was for naught.  My search continues….